Just my luck!!

No sooner have I upgraded to Wordpress 2.1.1 than this comes out:

WordPress 2.1.1 dangerous, Upgrade to 2.1.2


I've upgraded again. Hopefully that'll be it for a while!

Popular posts from this blog

Some Thoughts about Skills-Based Curricula

Planning for Learning or Planning for Behaviour?

My Leadership Story